2.1.2 System requirements

The following requirements do not include the system requirements for MetaDefender Core if installed on the same system.

Minimum hardware requirements

Hardware property

Requirement

Notes

RAM

4 GB

 

Free SSD space

16 GB

Space details

Please note that this hard disk space is only enough for installing MetaDefender Email Gateway Security and for very limited operation.

Quarantine and permanently failing emails (especially with large attachments) may consume huge disk volumes.

Performance concerns

For performance reasons it is not recommended to use HDD instead of SSD.

CPU

4 cores

 

Software requirements

Software property

Requirement

Notes

Distribution

Version(s)

Bitness

Operating system

Microsoft Windows

7 / 8 / 8.1 / 10

64 bit

 

 

Microsoft Windows Server

2008 R2 / 2012 / 2012 R2 / 2016 / 2019

64 bit

 

TLS toolkit

OpenSSL

latest

32 bit

Optional, it is needed only if TLS is utilized.

MetaDefender Core

Version compatibility matrix

MetaDefender Email Gateway Security

MetaDefender Core

4.0.0

4.7.0+

4.1.0 - 4.2.0

4.8.2+

Scan engines

The following scan engines must be active:

Scan engine

Version

Data sanitization

5.0.2-6 +

At least one of the available anti-malware engines

N/A

Security rules

Under Policy > Security rules on Core, security rules –that are used by MetaDefender Email Gateway Security's security rules–

  1. SHOULD enable the following Visibility of scan result:

    Role

    Visibility

    Everybody

    FULL DETAILS

    Without this visibility Email Gateway Security can still work, but certain details may not be provided on the UI.

Additional installation of 3rd party framework or components

Name

Version

Optional

.NET Framework

4.5

REQUIRED

Additional installation of Windows services

Name

Service Name

Optional

OPSWAT MetaDefender Email Gateway Security

mdemailsecurity

REQUIRED

Ports that must be available

Direction

Component / Service

Port

Note

Inbound

MetaDefender Email Gateway Security

SMTP service

10025

Customizable; adjust accordingly if modified.

Inbound

MetaDefender Email Gateway Security

Web Management Console and
REST interface

8058

Customizable; adjust accordingly if modified.

Outbound

MetaDefender Core

8008

only if MetaDefender Core is installed on a remote system.

Browser requirements

One of the following desktop browsers is required to use the Web Management Console:

  • Latest two Chrome versions

  • Latest two Firefox versions

  • Latest two Safari versions

  • Latest two Microsoft Edge versions

  • Internet Explorer 11

Mobile layouts are not supported yet.