Browser Requirements for the MetaDefender for Secure Storage Web Console

One of the following browsers is suggested to view the MetaDefender for Secure Storage Web Console:

  • Microsoft Edge

  • Chrome

  • Firefox

  • Safari

  • Internet Explorer 11+

Chrome, Firefox, Safari, and Edge browsers are tested with the latest available version at the time of release.

When using Internet Explorer it is necessary to add the MetaDefender for Secure Storage IP address or DNS to the trusted sites list. If you’re not using HTTPS it may also be necessary to lower the security level for the zone.