1.1.1 System requirements for Unix-based deployments

Supported Operating Systems

  • CentOS 7.0+

  • Red Hat Enterprise Linux 7.0+

  • Debian 9.0+

  • Ubuntu 18.04+

System requirements:

Hardware

Dedicated instance

Shared instance with MetaDefender Core

CPU

4 cores

10 cores

RAM

8 GB

16 GB

Free disk space

20 GB

40 GB

Installation details

MetaDefender for Secure Storage default installation path is using the /etc/mdss folder for storing resources. The package requires the following dependencies that are automatically installed if they don’t already exist on the system:

Debian / Ubuntu

Red Hat Enterprise / CentOS

  • curl

  • openssl

  • apt-transport-https

  • ca-certificates

  • gnupg-agent

  • software-properties-common

  • sudo

  • apt-utils

  • iproute2

  • jq

  • yum-utils

  • device-mapper-persistent-data

  • lvm2

  • curl

  • openssl

  • ca-certificates

  • gnupg2

  • sudo

  • iproute

  • wget

  • epel-release

  • jq

Installation components

MetaDefender for Secure Storage automatically deploys the following components:

Name

Version

Type

Docker Engine

v19.03.8

Containerization technology

Docker-compose

1.25.xx

Container Orchestration

MongoDb

v3.6

Database

RabbitMQ

v3.8

Message broker

NGINX

v1.16.1

Web server