Browser Requirements

For optimum use of MetaDefender Cloud, we recommend that you use the latest stable version of any of the following browsers:

  • Google Chrome

    • We support Chrome version 43.0.2357.124 and newer.

  • Mozilla Firefox

    • Firefox 26 and newer versions are supported. Users may encounter some issues in Firefox on Windows XP and Windows 7 – it is recommended to use the latest version of Firefox on fully updated Windows operating systems.

  • Microsoft Internet Explorer

    • We support version 11 of Internet Explorer, and all subsequent versions.

  • Microsoft Edge

    • MetaDefender Cloud supports all versions of Microsoft Edge.

  • Safari

    • Currently, Safari 5 on Windows 7 is not supported. We support both Safari 6 on OS X Mountain Lion and Safari 8 on OS X Yosemite, and all newer versions of Safari.

My browser isn't supported. What should I do?

We try to support as many browsers and browser versions as we feasibly can. If you are using an unsupported browser, we recommend that you follow the provided links and update to the latest version of your favorite browser.